Service unavailable: Towson University Website

Incident
November 17, 6:02pm

Service unavailable: Towson University Website

Status: closed
Created: November 17, 1:26pm
Start: November 17, 1:25pm
End: November 17, 6:02pm
Duration: 4 hours 37 minutes
Affected Components:
Web Content & Publishing University Website
Investigating

November 17, 1:25pm

November 17, 1:25pm

OTS is aware of a service outage affecting the Towson University Website. We're actively working to identify the cause and implement a resolution. An update will be made as information becomes available.

Monitoring

November 17, 2:05pm

November 17, 2:05pm

OTS has implemented a fix to restore the University Website. We will provide updates as needed with the possibility of a minor disruption after business hours for the full resolution.

Resolved

November 17, 6:02pm

November 17, 6:02pm

The issue impacting the University Website has been resolved.