Service disruption: NetID Management

Incident
January 08, 11:21am

Service disruption: NetID Management

Status: closed
Created: January 08, 9:07am
Start: January 08, 8:54am
End: January 08, 11:21am
Duration: 2 hours 27 minutes
Affected Components:
NetID & Duo NetID NetID Management
Investigating

January 08, 8:54am

January 08, 8:54am

NetID Management is having intermittent issues loading or displaying properly. These disruptions are not allowing for password resets or other account management. We will post an update when we have more information available.

Resolved

January 08, 11:21am

January 08, 11:21am

The issue impacting NetID Management has been resolved.