Scheduled Maintenance: Towson Online Services/PeopleSoft, PeopleSoft HCM, Timesheets

Maintenance
January 16, 11:04pm

Scheduled Maintenance: Towson Online Services/PeopleSoft, PeopleSoft HCM, Timesheets

Status: closed
Created: January 16, 9:15am
Start: January 16, 7:00pm
End: January 16, 11:04pm
Duration: 4 hours 4 minutes
Affected Components:
Towson Online Services/PeopleSoft & HR Systems Timesheets Towson Online Services (PeopleSoft) Human Resources (HCM)
Update

January 16, 7:00pm

January 16, 7:00pm

The Office of Technology Services (OTS) is performing the following system and infrastructure maintenance. 
Start:  January 16, 7:00pm
End:  January 16, 11:00pm

These services will be offline and unavailable during the maintenance window:

  • Timesheets
  • Human Resources (HCM)
  • Towson Online Services (PeopleSoft)
  • MyTU website login (online hub for students, faculty, and staff)


Resolved

January 16, 11:04pm

January 16, 11:04pm

Scheduled Maintenance on Towson Online Services (PeopleSoft), Human Resources (HCM), Timesheets is complete.

OTS Maintenance is complete - Services are now available 

Timesheets

Human Resources (HCM)

Towson Online Services (PeopleSoft)

MyTU website login (online hub for students, faculty, and staff)