Scheduled Maintenance Notice: PrintCenter

Maintenance
January 20, 11:15am

Scheduled Maintenance Notice: PrintCenter

Status: closed
Created: January 20, 7:31am
Start: January 20, 7:26am
End: January 20, 11:15am
Duration: 3 hours 49 minutes
Affected Components:
Other Services Other
Update

January 20, 7:26am

January 20, 7:26am

The Office of Technology Services (OTS) will perform scheduled maintenance to improve the reliability and performance of PrintCenter.
Start: January 20, 7:26am
End: January 20, 10:26am

Resolved

January 20, 11:15am

January 20, 11:15am

PrintCenter is now available.