Service disruption: Microsoft Outlook

Incident
January 23, 9:15am

Service disruption: Microsoft Outlook

Status: closed
Created: January 22, 3:23pm
Start: January 22, 3:16pm
End: January 23, 9:15am
Duration: 17 hours 59 minutes
Affected Components:
Microsoft 365 & Email Microsoft 365 Microsoft Outlook
Investigating

January 22, 3:16pm

January 22, 3:16pm

OTS is investigating reports of a service disruption with Microsoft Outlook. We will post an update when we have more information available.

Update

January 22, 11:07pm

January 22, 11:07pm

OTS is seeing indications that Microsoft email services are becoming available again; however, Microsoft reports that the issue is not yet fully resolved. Their engineers are continuing recovery efforts and refining systems to restore full service.

OTS is actively monitoring the status and will share additional updates as they become available.

Resolved

January 23, 9:15am

January 23, 9:15am

The issue impacting Microsoft Outlook has been resolved. Please note that some incoming emails could not be received during the disruption.