Vendor Reports An Issue With DocuSign

Incident
May 12, 4:30pm

Vendor Reports An Issue With DocuSign

Status: closed
Created: May 12, 3:46pm
Start: May 12, 3:35pm
End: May 12, 4:30pm
Duration: 55 minutes
Affected Components:
Business Applications DocuSign
Update

May 12, 3:35pm

May 12, 3:35pm

The vendor is reporting an issue with DocuSign that is impacting PowerForm links. OTS is monitoring the vendor status reports and will update as information is received.

Resolved

May 12, 4:30pm

May 12, 4:30pm

The vendor has reported that the issue for DocuSign is resolved.