Service disruption: Timesheets, myTU
Incident
May 26, 9:38am
Service disruption: Timesheets, myTU
Status: closed
Created:
May 26, 9:19am
Start:
May 26, 9:16am
End:
May 26, 9:38am
Duration: 22 minutes
Affected Components:
Towson Online Services/PeopleSoft & HR Systems
Web Content & Publishing
Timesheets
myTU
Investigating
May 26, 9:16am
May 26, 9:16am
OTS is investigating reports of a service disruption with Timesheets, myTU. We will post an update when we have more information available.
Resolved
May 26, 9:38am
May 26, 9:38am
The issue impacting Timesheets, myTU has been resolved.