Vendor reports issues accessing Microsoft 365

Incident
June 11, 9:00pm

Vendor reports issues accessing Microsoft 365

Status: closed
Created: June 11, 4:45pm
Start: June 11, 4:34pm
End: June 11, 9:00pm
Duration: 4 hours 26 minutes
Affected Components:
Microsoft 365 & Email Microsoft 365 Microsoft Outlook OneDrive SharePoint Office Online Forms Bookings
Update

June 11, 4:34pm

June 11, 4:34pm

The vendor is reporting issues accessing Microsoft 365. OTS is monitoring the vendor status reports and will update as information is received. Accessing outlook.towson.edu is unaffected at this time.

Resolved

June 11, 9:00pm

June 11, 9:00pm

The vendor has reported that the issue affecting Microsoft 365 is resolved.