Service disruption: Power BI
Incident
July 17, 1:41pm
Service disruption: Power BI
Status: closed
Created:
July 17, 1:21pm
Start:
July 17, 1:18pm
End:
July 17, 1:41pm
Duration: 23 minutes
Affected Components:
Other Services
Power BI
Investigating
July 17, 1:18pm
July 17, 1:18pm
OTS is investigating reports of a service disruption with Power BI. Users off campus are seeing a certificate error when attempting to reach BI.towson.edu. We will post an update when we have more information available.
Resolved
July 17, 1:41pm
July 17, 1:41pm
The certificate issue impacting Power BI has been resolved.